If you have no edit button for the EXS24 Plugin or the edit button is missing all you have to do is go to preferences in Logic Pro then,

Check show advanced tools on (default is on)
Check advanced editing is on